Error running javadoc within an Ant build.
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   David_Morris
Posted On:   Thursday, June 26, 2008 11:17 AM

I get the following error when running a javadoc tag within an ANT build.xml file. Javadoc failed: java.io.IOException: Cannot run program "javadoc.exe": CreateProcess error=2, The system cannot find the file specified Please reply with specific suggestions. I already know that javadoc.exe must be in my class path. I have tried setting it in the OS class path, in the eclipse class path, in the Ant class path, pointing to both java_home and java_home/bin. I have also added tools.jar to the Ant class path. Nothing is working. Any help would be appreciated. I am running eclipse 3.3.0 and all other Ant functions seem to be working correctly.    More>>

I get the following error when running a javadoc tag within an ANT build.xml file.



Javadoc failed: java.io.IOException: Cannot run program "javadoc.exe": CreateProcess error=2, The system cannot find the file specified



Please reply with specific suggestions. I already know that javadoc.exe must be in my class path. I have tried setting it in the OS class path, in the eclipse class path, in the Ant class path, pointing to both java_home and java_home/bin. I have also added tools.jar to the Ant class path. Nothing is working.



Any help would be appreciated.



I am running eclipse 3.3.0 and all other Ant functions seem to be working correctly.

   <<Less

Re: Error running javadoc within an Ant build.

Posted By:   Anonymous  
Posted On:   Wednesday, July 2, 2008 10:08 AM

Is tools.jar added to
Prefeerences->ant_>runtime->global entries?
About | Sitemap | Contact