Log4J Question: loading properties file in as
0 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Sandy_xxx
Posted On:   Monday, September 3, 2007 09:06 AM

Hi! I'm a newbee with Log4J.. Well.. I'm working with Sun One Java System Application Server v.8.1, I have a properties file and the script in java with an hashtable who loads the values..then I can see this values loaded in JBuilder but it doesn't seems to work with my A.S. !!! I took care of configuration in the application server with the jar library and properties file in the right folder in the file system and with the path (if it is correct I don't have idea,well it is "/lib/log4j-1.2.14.jar" and "/lib/log4j.properties") into the A.S. console in the JVMSettings/PathSettings I tried into the java code both with an ab   More>>


Hi! I'm a newbee with Log4J.. Well.. I'm working
with Sun One Java System Application Server v.8.1,
I have a properties file and the script in java
with an hashtable who loads the values..then I
can see this values loaded in JBuilder but it
doesn't seems to work with my A.S. !!!



I took care of configuration in the application
server with the jar library and properties file
in the right folder in the file system and with
the path (if it is correct I don't have idea,well
it is "/lib/log4j-1.2.14.jar" and
"/lib/log4j.properties") into the A.S. console
in the JVMSettings/PathSettings
I tried into the java code both with an absolute
or a relative path in my class but it doesn't work..
I tried to test it but I can't have information in
my log server about what is wrong even if I try to
debug the application.



Mine is a server-side application (with a .jar
within an .ear and this .jar in issue contains
other three .jar) who is in remote communication
with the stand-alone/client-side of the application.



Is there something (or more) huge or tiny I forgot ?



Thanks in advance for help..

   <<Less
About | Sitemap | Contact