dcsimg
Iplanet 6.0 web-apps.xml config issue.
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   srini_vasan
Posted On:   Monday, October 30, 2006 03:44 PM

Hi, I would like to know the reason for marking webapps_enable="off" or "on" in server.xml. The issue I'm facing is when I say : and my web-apps.xml file looks like this: <?xml version="1.0" encoding="UTF-8"?> "http://developer.iplanet.com/webserver/dtds/iws-webapps_6_0.dtd"> maxSessions 2000 timeOut 150 reapInterval 150 If I make webapps_enable="on" and add a new URI as : I'm getting the following error message when I start my web server; vs(https-somapp.xyz.COM)SAX parser error: The content o   More>>

Hi,
I would like to know the reason for marking webapps_enable="off" or "on" in server.xml.

The issue I'm facing is when I say :


and my web-apps.xml file looks like this:
<?xml version="1.0" encoding="UTF-8"?>

"http://developer.iplanet.com/webserver/dtds/iws-webapps_6_0.dtd">




maxSessions
2000


timeOut
150


reapInterval
150





If I make webapps_enable="on" and add a new URI as :


I'm getting the following error message when I start my web server;
vs(https-somapp.xyz.COM)SAX parser error: The content of element type "vs" must match "(auth-native?,class-loader?,jsp-servlet?,parameter-encoding?,response-buffer?, response-cookie?,config-param*,role-mapping?,session-manager?,session-tracking?, session-cookie?,tempdir?,form-login-session?,web-app*)". in file:web-apps.xml at line number 22.


Kindly assist me as I'm a newbie to Iplanet configurations.
Thanks in advance
SS

   <<Less

Re: Iplanet 6.0 web-apps.xml config issue.

Posted By:   Christopher_Koenigsberg  
Posted On:   Saturday, November 4, 2006 07:39 PM

The error message is trying to tell you that the elements you wrote in your server.xml do not come in the specific order specified by the DTD. I think the "?" after an element name means (0 or 1 of these, no more than 1) and the "*" means (any number, 0 or more, of these).



It looks to me like the main problem is that "parameter-encoding" has to come BEFORE "session-manager", not after it as you wrote ... and also make sure that your "web-app" comes AFTER "session-manager" ...
About | Sitemap | Contact