java.io.InvalidClassException with JUnit on eclipse
0 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Josiane_Roger
Posted On:   Thursday, September 14, 2006 12:42 PM

I am having trouble running JUnit on eclipse with a weblogic application. I am building with ANT my project and deploy on weblogic. Then I try to run JUnit from eclipse and I get the following exception: <2006-09-14 12 h 41 EDT> java.io.InvalidClassException: com.db.eps.ess.repository.domain.ApplicationContext; local class incompatible: stream classdesc serialVersionUID = -1439488433368555216, local class serialVersionUID = 2557661716428603012 java.io.InvalidClassException: com.db.eps.ess.repository.domain.ApplicationContext; local class incompatible: stream classdesc serialVersionUID = -1439488433368555216, local class serialVersionUID = 2557661716428603012 at java.io.ObjectS   More>>

I am having trouble running JUnit on eclipse with a weblogic application.


I am building with ANT my project and deploy on weblogic.

Then I try to run JUnit from eclipse and I get the following exception:

			
<2006-09-14 12 h 41 EDT>
java.io.InvalidClassException: com.db.eps.ess.repository.domain.ApplicationContext; local class incompatible: stream classdesc serialVersionUID = -1439488433368555216, local class serialVersionUID = 2557661716428603012
java.io.InvalidClassException: com.db.eps.ess.repository.domain.ApplicationContext; local class incompatible: stream classdesc serialVersionUID = -1439488433368555216, local class serialVersionUID = 2557661716428603012
at java.io.ObjectStreamClass.initNonProxy(ObjectStreamClass.java:463)


I verify and I have only JDK 1.4.2 from bea weblogic 8.1. I removed all other JDK and I still get this error.

How can I resolve it?

Thanks !    <<Less
About | Sitemap | Contact