JNUIT while testing the installation gives foll error:-java.lang.UnsupportedClassVersionError
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Rajesh_Choudhari
Posted On:   Tuesday, July 25, 2006 06:06 AM

I am trying to test whether junit is working, by the trying the following at the command prompt(and I am getting the foll result):- D:>java org.junit.runner.JUnitCore org.junit.tests.AllTests Exception in thread "main" java.lang.UnsupportedClassVersionError: org/junit/runner/J UnitCore (Unsupported major.minor version 49.0) at java.lang.ClassLoader.defineClass0(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:537) ...................etc. I feel it could be the problem with the JDK compatibility. Would appreciate if someone having faced a similar problem, could help in it. Thanks in Advance.    More>>

I am trying to test whether junit is working, by the trying the following at the command prompt(and I am getting the foll result):-

D:>java org.junit.runner.JUnitCore org.junit.tests.AllTests
Exception in thread "main" java.lang.UnsupportedClassVersionError: org/junit/runner/J
UnitCore (Unsupported major.minor version 49.0)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:537)
...................etc.

I feel it could be the problem with the JDK compatibility. Would appreciate if someone having faced a similar problem, could help in it.

Thanks in Advance.

   <<Less

Re: JNUIT while testing the installation gives foll error:-java.lang.UnsupportedClassVersionError

Posted By:   Rajesh_Choudhari  
Posted On:   Wednesday, July 26, 2006 09:01 AM

The Problem is solved. JUNIT 4.1 works only with JDK-1.5.
It won't work with JDK-1.4
About | Sitemap | Contact