Ant build problem
0 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   nonno_lee
Posted On:   Thursday, June 29, 2006 08:57 PM

I'm trying to use neatbeans 5.0 as the IDE to program a web application. This web application and its ant script are previously written by my colleagues, they used to compile by command and debug by interleaving System.out.print() into the source code, which are very ineffective ways. I created a netbeans 5.0 project of "Web Application with Existing Ant Script" for it, when I compile it, the output pane shows that the ant script is started, but an error occurs: Try to increase heap size. Can be done by defining ANT_OPTS=-Xmx640m See the JDK tooldocs. C:devMyOffice uild.xml:53: null BUILD FAILED (total time: 37 seconds) I already set the environment variable, ANT_OPTS=-Xmx640m, in    More>>

I'm trying to use neatbeans 5.0 as the IDE to program a web application. This web application and its ant script are previously written by my colleagues, they used to compile by command and debug by interleaving System.out.print() into the source code, which are very ineffective ways. I created a netbeans 5.0 project of "Web Application with Existing Ant Script" for it, when I compile it, the output pane shows that the ant script is started, but an error occurs:


Try to increase heap size. Can be done by defining ANT_OPTS=-Xmx640m

See the JDK tooldocs.

C:devMyOffice uild.xml:53: null

BUILD FAILED (total time: 37 seconds)


I already set the environment variable, ANT_OPTS=-Xmx640m, in my Windows XP. The ant script really can build the webapp in command mode, but why netbeans still get that error?

   <<Less
About | Sitemap | Contact