ant with pmd 3.7
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Ernst_Reissner
Posted On:   Saturday, June 17, 2006 06:30 AM

Hi all, i just updated to PMD 3.7 while i want to stay with Apache Ant version 1.6.1 compiled on February 12 2004. running my old pmd-task as usual takes a while and then yields: BUILD FAILED /home/ernst/Software/build.xml:177: net.sourceforge.pmd.PMDException: Error while processing /home/ernst/Software/src/eu/simuline/testhelpers/Accessor.java Total time: 54 seconds whithout further comment. My build-file looks as follows depends="init" description="Defines the pmd-task. ">    More>>

Hi all,

i just updated to PMD 3.7 while i want to stay with
Apache Ant version 1.6.1 compiled on February 12 2004.


running my old pmd-task as usual takes a while
and then yields:



BUILD FAILED

/home/ernst/Software/build.xml:177:

net.sourceforge.pmd.PMDException:

Error while processing /home/ernst/Software/src/eu/simuline/testhelpers/Accessor.java



Total time: 54 seconds


whithout further comment.


My build-file looks as follows




depends="init"

description="Defines the pmd-task. ">





location="/usr/local/pmd/latest/"/>













classname="net.sourceforge.pmd.ant.PMDTask"

classpathref="pmd.classpath"/>









depends="initPMD"

description="Performs a static code check using pmd. ">



rulesetfiles="/usr/local/pmd/latest/rulesets/basic.xml"

failonerror="yes"

failOnRuleViolation="yes"

shortFilenames="No"

targetjdk="1.5"

excludemarker="NOPMD">



toFile="pmdReportSrc.html"/>









failonerror="yes"
failOnRuleViolation="yes"
printToConsole="yes">





-->




what went wrong????



greetings


ernst

   <<Less

Re: ant with pmd 3.7

Posted By:   Anonymous  
Posted On:   Tuesday, June 20, 2006 12:54 AM

Can you run with "-debug"?
About | Sitemap | Contact