java.lang.UnsatisfiedLinkError in tomcat5
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Jerry_Lin
Posted On:   Thursday, May 11, 2006 09:51 PM

I have a lib name libAmadeusProxy.so and in it there's a method name initConvFactory() written in c. The code runs fine when I run it in command line, however as soon as I run the program in Tomcat 5, the error "java.lang.UnsatisfiedLinkError: initConvFactory occurs".
I've double checked, firstly the library is loaded correctly, because if delete libAmadeusProxy.so, the error becomes can't find library 'AmadeusProxy'.
Secondly the same set of codes works if I run it in command line.

Does anyone know what would be the cause for this ? anything to do with tomcat 5 ?

Thank you

Re: java.lang.UnsatisfiedLinkError in tomcat5

Posted By:   Anonymous  
Posted On:   Friday, June 23, 2006 02:06 PM

Did you saw what are defined in the java.library.path system property. In your code, do something like that:



System.out.println(System.getProperty("java.library.path"));


Then, just copy your lib for one of the directories defined in this property.

Regards,

Joao
About | Sitemap | Contact