Classpath problem - Jar files not recognizing from EAR in Websphere Application Server V6.0
0 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   plavanya_pervela
Posted On:   Tuesday, May 2, 2006 06:30 AM

Hi All, I am using Websphere Application Server V6.0 (Admin Console) for my application. While deploying the application, I am getting classpath problems. All the required .jar files are present in the .ear. I have five EJB modules which are dependent on each other and some utility jar files.I have mentioned all the required .jar files in the META-INFMANIFEST.MF file of web-module. I am getting NoClassDefFoundError . If I am copying all the .jar files into the Application server's lib, then my application is working fine. Are there any options to be made through the console? I tried changing the classloader mode option in admin console from PARENT_FIRST to PARENT_LAST. But this did not    More>>



Hi All,


I am using Websphere Application Server V6.0 (Admin Console) for my application. While deploying the application, I am getting classpath problems. All the required .jar files are present in the .ear. I have five EJB modules which are dependent on each other and some utility jar files.I have mentioned all the required .jar files in the META-INFMANIFEST.MF file of web-module. I am getting NoClassDefFoundError . If I am copying all the .jar files into the Application server's lib, then my application is working fine.




Are there any options to be made through the console? I tried changing the classloader mode option in admin console from PARENT_FIRST to PARENT_LAST. But this did not work.





I have tried all the options but not loading the .jar files from the application.




Please help on the same.




Thanks in advance,


Lavanya    <<Less
About | Sitemap | Contact