Websphere-Apache configuration
0 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Abhay_Shukla
Posted On:   Friday, February 24, 2006 03:46 PM

I am using Websphere 5.1 and apache 1.3. My application deployed on websphere is working fine. All pages have a .do extension. Whenver a page is requested, apache uses the plug-in configuration and forward the request to websphere. All pages are served appropriately. However when my application is down (or appserver is down), the webserver is supposed to show my customized error page. This is the entry in httpd.conf file ErrorDocument 404 /Unavailable.htm and this is the log entry for a url http://abhay/ecom/page1.do (when appserver is down) 127.0.0.1 - - [24/Feb/2006:15:12:23 - 0500] "GET /ecom/page1.do HTTP/1.1" 404 158 As per the   More>>

I am using Websphere 5.1 and apache 1.3. My application deployed on websphere is working fine.
All pages have a .do extension. Whenver a page is requested, apache uses the plug-in configuration and forward the request to websphere. All pages are served
appropriately.

However when my application is down (or appserver is down), the webserver is supposed to show my customized error page.


This is the entry in httpd.conf file

ErrorDocument 404 /Unavailable.htm


and this is the log entry for a url

http://abhay/ecom/page1.do (when appserver is down)


127.0.0.1 - - [24/Feb/2006:15:12:23 - 0500] "GET /ecom/page1.do HTTP/1.1" 404 158


As per the settings in httpd.cong, I should see the Unavailable.htm page. However, I see the usual IE 404 'Page cannot be found' page.
Why is the web server not showing up my customized error page ?

   <<Less
About | Sitemap | Contact