Tomcat redirect from HTTP to HTTPS fails with IE
0 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Anonymous
Posted On:   Friday, October 7, 2005 09:35 AM

I've configured an SSL Tomcat connector and my whole application as CONFIDENTIAL with "FORM" auth-method. With Firefox every thing works right: I request for "http://myHost:8080/myApp/welcome.do" and the browser is redirected to my "login.jsp" that is built with the HTML base tag as href="https://myHost:8443/myApp/login.jsp" . However with IE (6.0 SP1) this value is href="https://myHost:8080/myApp/login.jsp" , so then the resources cannot be loaded and the login form submit fails. Do you know what is going on? Do you suggest a workaround? Where do you think is the problem: IE, Tomcat, my Tomcat configuration, my application?. Thanks in ad   More>>

I've configured an SSL Tomcat connector and my whole application as CONFIDENTIAL with "FORM" auth-method. With Firefox every thing works right: I request for "http://myHost:8080/myApp/welcome.do" and the browser is redirected to my "login.jsp" that is built with the HTML base tag as href="https://myHost:8443/myApp/login.jsp" .


However with IE (6.0 SP1) this value is href="https://myHost:8080/myApp/login.jsp" , so then the resources cannot be loaded and the login form submit fails.


Do you know what is going on? Do you suggest a workaround? Where do you think is the problem: IE, Tomcat, my Tomcat configuration, my application?.


Thanks in advance for your help...

   <<Less
About | Sitemap | Contact