java.net.ConnectException: Connection refused
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   muthu_raman
Posted On:   Tuesday, June 14, 2005 05:32 AM

Guys, I have been stuck on this for some time now. Does anyone have any idea?. Basically it is all ok, if I run both the server and the client in the same pc(w2k). But the problem arises when I try to run the server and client in different machines. I got 'java.net.ConnectException: Connection refused' error when launching the client (the server is up and running) 1.I don't have any firewall running. 2.I tried to include a policy file by specifying in the command line like java -classpath suncertify.jar -Djava.security.policy=D:SoftwaredistmyPolicy.policy urlyBird.gui.Client Network where myPolicy.policy is grant { permission java.net.SocketPermission &quo   More>>

Guys,


I have been stuck on this for some time now. Does anyone have any idea?.

Basically it is all ok, if I run both the server and the client in the same pc(w2k). But the problem arises when I try to run the server and client in different machines. I got 'java.net.ConnectException: Connection refused' error when launching the client (the server is up and running)



1.I don't have any firewall running.
2.I tried to include a policy file by specifying in the command line like

java -classpath suncertify.jar -Djava.security.policy=D:SoftwaredistmyPolicy.policy urlyBird.gui.Client Network



where myPolicy.policy is
			
grant {
permission java.net.SocketPermission "*:1024-65535", "accept, connect, listen";
};


3. I create the registry programatically by java.rmi.registry.LocateRegistry.createRegistry(port);




One more question - why I am not able to start server in any other port than 1099?



Thanks,

Muthu.    <<Less

Re: java.net.ConnectException: Connection refused

Posted By:   muthu_raman  
Posted On:   Tuesday, June 14, 2005 08:28 PM

Hmm, I have figured out my problem. I was binding the server with



"rmi//" + InetAddress.getLocalHost().getHostAddress().trim() + ":" + port + "/" + rmiName;

which was wrong. It should have been

"//localhost:"+port+"/"+rmiName




Muthaiah.
About | Sitemap | Contact