NullPointerException in getLogger()
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Louie_W
Posted On:   Friday, June 10, 2005 06:04 PM

I'm using log4j 1.2.9 and JDK 1.5.0. Whenever getLogger() runs, I get the error below. It's probably something stupid but I'm stumped.



javax.xml.parsers.FactoryConfigurationError: Provider com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderFactoryImpl could not be instantiated: java.lang.NullPointerException

Re: NullPointerException in getLogger()

Posted By:   Louie_W  
Posted On:   Monday, June 13, 2005 10:49 AM

Actually, I have some additional information on this. The problem only occurs when I run through an ant script. When I run using "java" then it works.



I have confirmed that ant is using JDK 1.5 by running in debug mode.



It seems to be some strange interaction between ant and log4j, probably having to do with a classpath or environment property however I can't figure out what it is.



I use the same classpath in ant and the java command line.



jon

About | Sitemap | Contact