Eclipse: External Tools to run mysql blanks console area...
0 posts in topic
Flat View  Flat View

Posted By:   Jim_Wilson
Posted On:   Sunday, April 24, 2005 11:00 AM

I am trying to write a voice chat using JMF. In JMF there is an implementation of the Real-Time Transport Protocol and RTCP (for control). They allow the streaming of audio and video over the Internet. If you are using just UDP, should'nt write yourself what RTP-RTCP already provide? for instance reordering the packets out of sequence. Below is a test code that should work in theory. I have been able to make two participants in different computers to talk to each other in a LAN. But the third one has problems. The difficulty I have found is that RTPManager seems not being issuing all the events. When a stream is received from a remote participant I list   More>>

I've added my own External Tool to Eclipse 3.1 M6.

It runs the mysql command line tool. I use it to debug SQL scripts I am developing. The definition is below.

However, it has one very annoying problem. When I run it the first time, it runs successfully, very briefly displays output in the console window, then blanks out the Console window. If I run it a second time, it works as expected.

The behaviour is actually a bit more erratic than that. Sometimes it will work the first time, other times it takes a double run. For the most part, I have to run it twice to see results.

I would guess it is some kind of timing problem, or issue with running External Tool that redirects stdin.

The net is that I have to run the command twice every time




-c "mysql -t --batch -u user -ppassword db <${resource_loc}"

About | Sitemap | Contact