Error initializing log4j in Struts app
0 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   L_C
Posted On:   Thursday, October 7, 2004 07:54 AM

I'm running a struts app in WebLogic. I'm trying to use Log4j for logging, but am getting the following errors in the console: log4j:WARN No appenders could be found for logger (org.apache.struts.util.PropertyMessageResources). log4j:WARN Please initialize the log4j system properly. Logging seems to be working because my messages are being output to the appender. I'm also seeing the following messages to the console (which I don't want to see): INFO util.PropertyMessageResources - Initializing, config='org.apache.struts.actions.LocalStrings', returnNull=true INFO util.PropertyMessageResources - Initializing, config='org.apache.struts.taglib.html.   More>>

I'm running a struts app in WebLogic. I'm trying to use Log4j for logging, but am getting the following errors in the console:


log4j:WARN No appenders could be found for logger (org.apache.struts.util.PropertyMessageResources).




log4j:WARN Please initialize the log4j system properly.




Logging seems to be working because my messages are being output to the appender. I'm also seeing the following messages to the console (which I don't want to see):


INFO util.PropertyMessageResources - Initializing, config='org.apache.struts.actions.LocalStrings', returnNull=true




INFO util.PropertyMessageResources - Initializing, config='org.apache.struts.taglib.html.LocalStrings', returnNull=true.




Any ideas how I can set this up so that I don't receive these initialize message?

   <<Less
About | Sitemap | Contact