Upgrade a production router to v5.1.0
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Karl_Cassaigne
Posted On:   Thursday, September 30, 2004 10:19 AM

Hello, I'd like to upgrade a production router currently running version 5.0.1 to 5.1.0 without having to reconfigure everything as the service cannot be interrupted very long. What is the best way to do this upgrade ? I was thinking about this procedure : 1) install the new version besides the old one 2) copy the routerconfig.xml file of the old version in the config directory of the new version 3) stop the old one 4) start the new one Is this correct ? Besides, I notice that the 5.1.0 explorer seems not to be compatible with older swiftmq router... does it mean that the entire router network should be upgraded to    More>>

Hello,

I'd like to upgrade a production router currently running version 5.0.1 to 5.1.0 without having to reconfigure everything as the service cannot be interrupted very long.



What is the best way to do this upgrade ?


I was thinking about this procedure :


1) install the new version besides the old one

2) copy the routerconfig.xml file of the old version in the config directory of the new version

3) stop the old one

4) start the new one



Is this correct ?


Besides, I notice that the 5.1.0 explorer seems not to be compatible with older swiftmq router... does it mean that the entire router network should be upgraded to v5.1.0 in order to be able to manage it with the new explorer ?



Thanks

   <<Less

Re: Upgrade a production router to v5.1.0

Posted By:   Andreas_Mueller  
Posted On:   Thursday, September 30, 2004 10:26 AM

It's correct but you should do this as well (if you are using the standard filebasedf store):


3a) Copy the store directory of the old one to the new one.


SwiftMQ Explorer 5.1.0 uses a new protocol version so you must connect to a 5.1.0 router. But you can manage all other routers with lower versions from this 5.1.0 router so you can upgrade step by step. You can use a 5.0.1 Explorer to connect to a 5.1.0 router and manage everything.
About | Sitemap | Contact