Tomcat Deploying JAR
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   ben_davidson
Posted On:   Friday, August 6, 2004 03:18 PM

Hi All, I have Tomcat 4.0.1 and have a webapp with a package that stores all the java application beans. These numerous bean class files are referenced in the application. For example, C: omcat401webappsmyappWEB-INFclassespkgname contains all the *.class bean files within the package. They want to JAR these files and still reference them. JAR'ed them and tried putting the JAR in a lib directory as documentation says. Put them in C: omcat401webappsmyappWEB-INFlib and got an error below. Class org.apache.jsp.pkgname.MY_110_Bean not found. Where do I deploy the JAR? Are there settings that I am missing? Any help would be   More>>

Hi All,


I have Tomcat 4.0.1 and have a webapp with a package that stores all the java application beans. These numerous bean class files are referenced in the application.


For example, C: omcat401webappsmyappWEB-INFclassespkgname contains all the *.class bean files within the package. They want to JAR these files and still reference them.


JAR'ed them and tried putting the JAR in a lib directory as documentation says.
Put them in
C: omcat401webappsmyappWEB-INFlib and got an error below.


Class org.apache.jsp.pkgname.MY_110_Bean not found.


Where do I deploy the JAR? Are there settings that I am missing?


Any help would be appreciated



Thanks

BD

   <<Less

Re: Tomcat Deploying JAR

Posted By:   AlessandroA_Garbagnati  
Posted On:   Sunday, August 8, 2004 01:04 AM

Hi,

What you have done it is correct, but there is something strange. You said that Tomcat is not finding the "org.apache.jsp.pkgname.MY_110_Bean", and this is something that makes me thinking that there is something strange inside the code that is trying to use your classes. It should not look for "org.apache.jsp.pkgname.MY_110_Bean" but for "pkgname.MY_110_Bean".

Are you importing your classes correctly inside your servlets or jsps?
About | Sitemap | Contact