Tomcat Mbeans
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Csaba_Nemeti
Posted On:   Friday, July 2, 2004 02:47 AM

Hello. I had a problem with my Tomcat. I want to register an MBean but I think is not working. Here is what I did: 1. In server.xml I add the following line debug="9" descriptors="/com/artsoft/equal/mbean-descriptor.xml"/> 2. In Tomcat-5.0.25commonclassescomartsoftequal I add in mbean-descriptor.xml file: <?xml version="1.0"?> description="Used start the eQual System" domain="Catalina" group="Realm"> 3. In Tomcat-5.0.25commonclasses oartsoftequalmicrokernel directory I add the TomcatStarter.class. This class has only a constructor with a system out. It not implements/extends   More>>

Hello.
I had a problem with my Tomcat. I want to register an MBean but I think is not working. Here is what I did:
1. In server.xml I add the following line

			

debug="9" descriptors="/com/artsoft/equal/mbean-descriptor.xml"/>

2. In Tomcat-5.0.25commonclassescomartsoftequal I add in mbean-descriptor.xml file:
			
<?xml version="1.0"?>


description="Used start the eQual System" domain="Catalina" group="Realm">



3. In Tomcat-5.0.25commonclasses
oartsoftequalmicrokernel directory I add the TomcatStarter.class. This class has only a constructor with a system out. It not implements/extends any interface/class.
Now my problems:
a. the message for system.out is not visible. Do you have any ideas why?
b. is a tool available for see the registered mbeans from Tomcat?    <<Less

Re: Tomcat Mbeans

Posted By:   Christopher_Koenigsberg  
Posted On:   Friday, July 2, 2004 01:52 PM

what about system.err, can you at least find the message for that?
About | Sitemap | Contact