Problem with turkish special character in IE 5.0 and 5.5
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Shyamala_S
Posted On:   Tuesday, March 9, 2004 04:02 AM

We are facing a strange problem with Turkish special characters display on IE 5.0 and IE 5.5. The characters causing problems are Ğ, İ, Ş, ğ, ı, ş and ç. These characters work fine on IE 6.0. On IE 5.0 and 5.5 they are displayed as junk characters(thick black blocks) in the java script alert messages. They are however displayed properly on the html page. We tried the following script: alert("Test ğ"); alert(String.fromCharCode(287)); alert("Test xF0"); --> and none of them seemed to work. It still displays them as junk in the alerts. Can anyone please advice on how this can be solved? Thanks and Best Regards, Shyamala.    More>>

We are facing a strange problem with Turkish special characters display on IE 5.0 and IE 5.5. The characters causing problems are Ğ, İ, Ş, ğ, ı, ş and ç. These characters work fine on IE 6.0.
On IE 5.0 and 5.5 they are displayed as junk characters(thick black blocks) in the java script alert messages. They are however displayed properly on the html page. We tried the following script:

			




and none of them seemed to work. It still displays them as junk in the alerts. Can anyone please advice on how this can be solved?


Thanks and Best Regards,

Shyamala.    <<Less

Re: Problem with turkish special character in IE 5.0 and 5.5

Posted By:   Firat_Tiryaki  
Posted On:   Wednesday, March 10, 2004 04:55 AM

use your script as an external *.js file and set the character encoding while retrieving the source of it




About | Sitemap | Contact