dcsimg
Unable to run JSP 2.0 examples in Tomcat 5
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Zenon_Rzepczynski
Posted On:   Friday, February 20, 2004 10:07 AM

Having installed Tomcat 5.0.18 after removing Tomcat 4, all works except when I try to run any JSP 2.0 examples I get a range of errors such as


java.lang.VerifyError: (class: org/apache/jsp/jsp2/simpletag/hello_jsp, method: _jspx_meth_mytag_helloWorld_0 signature: (Ljavax/servlet/jsp/PageContext;)Z) Incompatible argument to function

Re: Unable to run JSP 2.0 examples in Tomcat 5

Posted By:   Anonymous  
Posted On:   Friday, February 20, 2004 10:34 PM

Hi, the problem must be that you have duplicate libraries wich are not consistent...is there anywhere in your classpath a tomcat 4 version of servlet.jar? In tomcat 5, there should only be jsp-api.jar and servlet-api.jar.

Cheers,
About | Sitemap | Contact