JDeveloper runtime error after changing compiler to 1.4.2_02 from 1.3.1_02
3 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   neal_ravindran
Posted On:   Wednesday, November 19, 2003 11:10 AM

I have a J2EE running fine under the default compiler provided in JDeveloper, namely 1.3.1_02. I changed the compiler to 1.4.2_02 and things compiled fine. But at run time get this error:- "InsuranceHome_StatelessSessionHomeWrapper1.java:9: cannot access java.lang.Object bad class file: D:jdk1.4.202jrelib t.jar(java/lang/Object.class) class file has wrong version 48.0, should be 47.0 Please remove or make sure it appears in the correct subdirectory of the classpath. public class InsuranceHome_StatelessSessionHomeWrapper1 extends com.evermind.server.ejb.RemoteStatelessSessionEJBHome implements com.XXXlink.xyz.ejb.InsuranceHome ^    More>>

I have a J2EE running fine under the default compiler provided in JDeveloper, namely 1.3.1_02. I changed the compiler to 1.4.2_02 and things compiled fine.
But at run time get this error:-


"InsuranceHome_StatelessSessionHomeWrapper1.java:9: cannot access java.lang.Object
bad class file: D:jdk1.4.202jrelib
t.jar(java/lang/Object.class)

class file has wrong version 48.0, should be 47.0
Please remove or make sure it appears in the correct subdirectory of the classpath.



public class InsuranceHome_StatelessSessionHomeWrapper1 extends

com.evermind.server.ejb.RemoteStatelessSessionEJBHome implements com.XXXlink.xyz.ejb.InsuranceHome


^
Error compiling D:insuranceDevWorkspacesProjectsclasses: Syntax error in source



1 error
Oracle9iAS (9.0.3.0.0) Containers for J2EE initialized

javax.naming.NameNotFoundException: InsuranceEJB not found

at com.evermind.server.rmi.RMIContext.lookup(RMIContext.java:130)



at com.evermind.server.ApplicationContext.lookup(ApplicationContext.java:195)



at com.evermind.server.ApplicationContext.lookup(ApplicationContext.java:66)



at javax.naming.InitialContext.lookup(InitialContext.java:347)



at com.XXXlink.xyz.struts.DisplayInsurancePageInitAction.execute(DisplayInsurancePageInitAction.java:55)



at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:484)



at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:274)



at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1482)



at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:525)



at javax.servlet.http.HttpServlet.service(HttpServlet.java:760)



at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)



at com.evermind.server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:721)



at com.evermind.server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:306)



at com.evermind.server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:767)



at com.evermind.server.http.HttpRequestHandler.run(HttpRequestHandler.java:259)



at com.evermind.server.http.HttpRequestHandler.run(HttpRequestHandler.java:106)



at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Worker.run(PooledExecutor.java:797)



at java.lang.Thread.run(Thread.java:534)



Process exited.

   <<Less

Re: JDeveloper runtime error after changing compiler to 1.4.2_02 from 1.3.1_02

Posted By:   J_R  
Posted On:   Thursday, January 29, 2004 11:08 PM

Make sure the classpath is pointing to new jdk versiob before U run.

Re: JDeveloper runtime error after changing compiler to 1.4.2_02 from 1.3.1_02

Posted By:   shay_shmeltzer  
Posted On:   Tuesday, November 25, 2003 02:43 PM

Maybe the problem is that the OC4J that you are trying to run can't run with JDK 1.4 ?
Try posting this on the OTN OC4J discussion forum.
http://forums.oracle.com/forums/index.jsp?cat=13

Re: JDeveloper runtime error after changing compiler to 1.4.2_02 from 1.3.1_02

Posted By:   neal_ravindran  
Posted On:   Wednesday, November 19, 2003 11:32 AM

I was able to figure this out:-

Culprit= old jdk 1.3.1_01 tools.jar

Removed /jdk/lib/tools.jar and placed in the one from jdk1.4.2_02/lib
About | Sitemap | Contact