XDoclet 1.1.2 and JBoss 3.2.2
3 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   David_Horner
Posted On:   Wednesday, November 12, 2003 03:51 AM

Hi, I am new to XDoclet and have been trying to use version 1.1.2 to generate Home / Remote interfaces and ejb-jar.xml for JBoss 3.2.2. I found an example ant build script based around Jboss 3.0, which contained the ejbdoclet tag below. However, it will not let me enter a JBoss version above 3.0, so I was wondering.... Does this matter, i.e. will it still generate correctly for JBoss 3.2.2 ? Do I need to move to XDoclet 1.2 for JBoss 3.2.2 ? Any help very much appreciated. Dave sourcepath="${src.ejb.dir}" destdir="${build.generate.dir}" classpathref="base.path" excludedtag   More>>

Hi,

I am new to XDoclet and have been trying to use version 1.1.2 to generate Home / Remote interfaces and ejb-jar.xml for JBoss 3.2.2.

I found an example ant build script based around Jboss 3.0, which contained the ejbdoclet tag below.

However, it will not let me enter a JBoss version above 3.0, so I was wondering....

Does this matter, i.e. will it still generate correctly for JBoss 3.2.2 ?

Do I need to move to XDoclet 1.2 for JBoss 3.2.2 ?

Any help very much appreciated.

Dave




			


sourcepath="${src.ejb.dir}"
destdir="${build.generate.dir}"
classpathref="base.path"
excludedtags="@version,@author"
ejbspec="${ejb.version}"
mergedir="${src.resources.dir}/xdoclet"
force="${xdoclet.force}"
>









xmlencoding="UTF-8"
typemapping="${type.mapping}"
destdir="${build.jboss}/META-INF"
validateXml="false"
/>


   <<Less

Re: XDoclet 1.1.2 and JBoss 3.2.2

Posted By:   Maxim_Wirt  
Posted On:   Wednesday, December 10, 2003 01:02 AM

jboss.version for 3.2.2 should be "3.2" then you'll be able to use all features of 3.2.x like read-only methods etc.

Re: XDoclet 1.1.2 and JBoss 3.2.2

Posted By:   Shahri_Faiz  
Posted On:   Wednesday, November 19, 2003 02:23 AM

Supported versions are 2.4 and 3.0.
And this attribute is optional.
Default is "2.4".

Re: XDoclet 1.1.2 and JBoss 3.2.2

Posted By:   Shahri_Faiz  
Posted On:   Wednesday, November 19, 2003 01:53 AM

I think specifying the version as 'Jboss 3.0' would be fine regardles of the latter values (i.e. 3.x.x). So, it'll work for any 3.x.x versions.
About | Sitemap | Contact