How to prevent OS/400 from unloading servlets after Tomcat4.1.27 server idle time
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Alex_Pinsky
Posted On:   Tuesday, November 11, 2003 08:02 AM

Hi all, I'm trying to upgrade from Tomcat3.2.4 to Tomcat4.1.27. Current version of Tomcat was installed as IBM PTF's and configured to run as 'in Process' with Apache1.3 HTTP server. I install Tomcat4.1.27 and configure it to run with Apache via Coyote connector (ajp13). Right now both servers run at a same time (each Apache sever/Topmcat version listen on a different port). I noticed that after some idle time on Tomcat4.1.27 it takes some time for a server to 'wake up' when first request is sent to the server. It is not the case with IBM's version of Tomcat... If anybody come accross the same problem and how to fix it, thanks Alex    More>>

Hi all,
I'm trying to upgrade from Tomcat3.2.4 to Tomcat4.1.27.

Current version of Tomcat was installed as IBM PTF's and configured to run as 'in Process' with Apache1.3 HTTP server.

I install Tomcat4.1.27 and configure it to run with Apache via Coyote connector (ajp13). Right now both servers run at a same time (each Apache sever/Topmcat version listen on a different port).

I noticed that after some idle time on Tomcat4.1.27 it takes some time for a server to 'wake up' when first request is sent to the server.
It is not the case with IBM's version of Tomcat...

If anybody come accross the same problem and how to fix it, thanks

Alex

   <<Less

Re: How to prevent OS/400 from unloading servlets after Tomcat4.1.27 server idle time

Posted By:   Larry_Halpern  
Posted On:   Tuesday, December 23, 2003 11:59 AM

What priority is your Tomcat job running at? Is it in its own subsystem or is it shared? How much memory is allocated to the subsystem?
About | Sitemap | Contact