dcsimg
Problem with List/Menu
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Bob_Leffew
Posted On:   Thursday, August 14, 2003 01:25 PM

I have inherited a site using javascript and am trying to learn the language. I have a problem I cant figure out. On my page I have a form with a List/Menu inside of a form. the value of the list box is a name that corresponds with a jpg in a defined directory and also corresponds with a html page in a defined directory. When you click on the List/Menu in real time the corresponding image changes accordingly and when the image is clicked on the correct page opens. But when I tried adding a new value to the Lis/Menu in development, in real time the image changes but html page does not. (Value of html remains contant) I definitely added a jpg into the proper directory   More>>

I have inherited a site using javascript and am trying to learn the language.

I have a problem I cant figure out.


On my page I have a form with a List/Menu inside of a form.


the value of the list box is a name that corresponds with a jpg in a defined
directory and also corresponds with a html page in a defined directory.


When you click on the List/Menu in real time the corresponding image changes
accordingly and when the image is clicked on the correct page opens.


But when I tried adding a new value to the Lis/Menu in development, in real
time the image changes but html page does not. (Value of html remains contant)


I definitely added a jpg into the proper directory with the proper value name
and also created a html page with the proper name.


All I can figure out is when I add in new values some type of index must be
being kept but I cant figure out where.


This is the URL that works before I add anything to the List/Menu:


http://www.childtechnologies.com/catalog.html


This is the URL that i am using for testing that I added items to the List/Menu
and now won't work.


http://www.childtechnologies.com/index2.html


Note: I have added all the additions to the List/Menu box. The only one I
have a actual page and jpg set up for is Infant Loft. (Third down from top).


In catalog.html when I click on a product in the list a corresponding picture
pops up to the right as does in index2.html.


When clicking on the picture in catalog.html it goes to the proper URL that
corresponds with the List item and picture.


When clicking on the picture in index2.html the URL it goes to is http://www.childtechnologies.com/ca...ariumStand.html


Which is the default URL.


Please help.

   <<Less

Re: Problem with List/Menu

Posted By:   Nitesh_Naveen  
Posted On:   Friday, August 15, 2003 02:49 AM

Well... when I tried it seemed to work!!! I clicked on Infat lot in the list, the image caame up, clicked on link and it took me to InstantLoft.html. I guess that is the expected behaviour!!! Tried this in IE6, Netscape 7 and Netscape 4.75. Wroked fine in all...
About | Sitemap | Contact