IBM WSAD is slow!
2 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Harsh_Soni
Posted On:   Tuesday, June 3, 2003 03:23 PM


WSAD runs on my machine having 1GB RAM. Yet it takes quite an amount of time to load a session bean file which is a bit large (64KB). Why is this so? Can something be done to make WSAD run faster?
One important input: The body of all methods in the session bean constitute just a call to a corresponding method in a normal java file.

Re: IBM WSAD is slow!

Posted By:   Adam_Clarricoates  
Posted On:   Wednesday, June 4, 2003 01:40 AM

Hi,

I also use WSAD 5 on a P4 with 1Gb RAM regularly. My experience is that the default config is far from optimal, but a few things help:



1) Upgrade to Fix Pack 1. This seems to make quite a difference.



2) Keep the workspace small and use multiple workspaces. I create a windows short-cuts for each workspace and use the -data option to specify which directory to use. EG



"C:Program FilesIBMWebSphere Studiowsappdev.exe" -data "C:WSADWorkspace1"



3) Under Window->Preferences, I turn off auto-compilation and validation:



Workbench->"Perform build automatically on resource modification"



and



Validation->"Run validation automatically when you save changes to a resource"

Re: IBM WSAD is slow!

Posted By:   Neo_Gigs  
Posted On:   Tuesday, June 3, 2003 07:23 PM

Hello there,


I am using IBM WSAD 5 with P4 2.4Ghz and 1GB RAM as well, but does not have problem with the loading time. Perhaps if your environment may need to set the JVM initial and maximum size to a more appropriate size?


Also if you are using TestEnvironment, set the server JVM argument size as well.


Another thing is the reason of DB, perhaps a local copy of DB will be faster?


Good luck !

About | Sitemap | Contact