cvs errors help me:-)
3 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Lauren_Gui
Posted On:   Friday, May 9, 2003 03:19 AM

HI,
I have cvs install in red hat(when I install red hat,cvs will be installed automately by rpm),
when I connect to cvs:
$cvs -d :pserver:cvsroot@192.168.1.77:/home/cvsroot login
CVS password:
cvs [login aboted]: connect to 192.168.1.77(192.168.1.77):2401 failed:Connection refused
I think I have set the cvs environment correctly.
but why the error occur???

Re: cvs errors help me:-)

Posted By:   Lauren_Gui  
Posted On:   Sunday, May 11, 2003 05:08 AM

now.an new error occur:
/home/cvsroot: no such repository

Re: cvs errors help me:-)

Posted By:   Lauren_Gui  
Posted On:   Sunday, May 11, 2003 04:37 AM

Yes.my os is red hat 8.0.
in /etc/services file,
the following is configed:
cvspserver 2401/tcp
cvspserver 2401/udp
and i have configed /etc/xinetd.d/cvsperver:
service cvspserver
{
disable=no
socket_type=stream
wait=no
user=root
protocol=tcp
env=HOME=
server=/usr/bin/cvs
server_args=-f --allow -root=/home/cvsroot pserver
}
but the same error comes again!

Re: cvs errors help me:-)

Posted By:   Thomas_Hackel  
Posted On:   Friday, May 9, 2003 04:00 AM

hi!


i assume you use xinted fro the cvs. check the /etc/xinetd.d/ directory if there is some file which could be a xinetd-cvs config file.


my cvspserver file:



service cvspserver
{
flags = REUSE
id = cvspserver
server = /usr/bin/cvs
server_args = -f --allow-root=/cvsroot pserver
socket_type = stream
wait = no
port = 2401
user = root
group = cvs
only_from = 10.0.0.0
log_type = FILE /var/log/cvs
log_on_success = HOST USERID
log_on_failure = HOST USERID ATTEMPT RECORD
disable = no
}



check the security stuff (ip,user etc) and you should able to connect to your cvs

About | Sitemap | Contact