Plug-in 1.4 does not load applet when server requires SSL client authentication
0 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Debora_Vargas
Posted On:   Wednesday, April 30, 2003 07:36 AM

We have an applet whose codebase is https://mywebserver.... It worked fine from Java Plug-in 1.4 until we changed the SSL configuration for mywebserver so client-authentication is required, through certificates. Now, the plug-in won't load the applet any more. Through traces we found out that when the plug-in issues an HTTP GET for the jar containing the applet, the server refuses to fulfill the request, returning "403 Access forbidden". The SSL trace shows that in the exchange, the client (ie. the java plug-in) does not present any certificate. We have tried many different ways of setting the keystore through the java plug-in java run-time parameters options, manually loading certificates in the default key   More>>

We have an applet whose codebase is https://mywebserver....
It worked fine from Java Plug-in 1.4 until we changed the SSL configuration for mywebserver so client-authentication is required, through certificates.
Now, the plug-in won't load the applet any more.
Through traces we found out that when the plug-in issues an HTTP GET for the jar containing the applet, the server refuses to fulfill the request, returning "403 Access forbidden".
The SSL trace shows that in the exchange, the client (ie. the java plug-in) does not present any certificate.
We have tried many different ways of setting the keystore through the java plug-in java run-time parameters options,
manually loading certificates in the default keystore (using the keytool provided with the plug-in), etc and nothing worked.

We have done extensive research in many forums and FAQs, but found nothing similar.

Any suggestions will be greatly appreciated.

   <<Less
About | Sitemap | Contact