dcsimg
Tomcat startup failing?
5 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   dan_cargile
Posted On:   Monday, April 28, 2003 12:38 PM

When I run the startup batch file, a second DOS window pops and a message appears but the window disappears before I can read it. Out of curiosity, I ran the shutdown batch and got this error message: Exception in thread "main" java.lang.NoClassDefFoundError: org/xml/sax/InputSource at java.lang.Class.newInstance0(Native Method) at java.lang.Class.newInstance(Class.java:232) at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:179) How can I get the startup window to stay up long enough to read the message so I can work on whatever is going wrong? Thanks, Dan    More>>

When I run the startup batch file, a second DOS window pops and a message appears but the window disappears before I can read it.

Out of curiosity, I ran the shutdown batch and got this error message:



Exception in thread "main" java.lang.NoClassDefFoundError: org/xml/sax/InputSource

at java.lang.Class.newInstance0(Native Method)

at java.lang.Class.newInstance(Class.java:232)

at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:179)




How can I get the startup window to stay up long enough to read the message so I can work on whatever is going wrong?

Thanks,
Dan

   <<Less

Re: Tomcat startup failing?

Posted By:   AlessandroA_Garbagnati  
Posted On:   Monday, May 12, 2003 02:42 PM

Re: Tomcat startup failing?

Posted By:   Rajesh_Joshi  
Posted On:   Monday, May 12, 2003 12:24 PM

I am having similar problem on Linux, have set the $CLASSPATH to point to the xerces.jar, doesn't seem to work, am i missing anything?

Re: Tomcat startup failing?

Posted By:   Rajesh_Joshi  
Posted On:   Monday, May 12, 2003 12:24 PM

I am having similar problem on Linux, have set the $CLASSPATH to point to the xerces.jar, doesn't seem to work, am i missing anything?

I also meet this problem!

Posted By:   raindrop_shy  
Posted On:   Wednesday, May 7, 2003 10:05 PM

Created catalinaLoader in: d:Program FilesApache GroupTomcat 4.1serverlib
[INFO] Registry - -Loading registry information
[INFO] Registry - -Creating new Registry instance
[INFO] Registry - -Creating MBeanServer
java.net.SocketException: Option unsupported by protocol: JVM_Bind
at java.net.PlainSocketImpl.socketBind(Native Method)
at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:405)
at java.net.ServerSocket.(ServerSocket.java:170)
at java.net.ServerSocket.(ServerSocket.java:121)
at org.apache.tomcat.util.net.DefaultServerSocketFactory.createSocket(DefaultServerSocketFactory.java:96)
at org.apache.tomcat.util.net.PoolTcpEndpoint.initEndpoint(PoolTcpEndpoint.java:265)
at org.apache.coyote.http11.Http11Protocol.init(Http11Protocol.java:150)
at org.apache.coyote.tomcat4.CoyoteConnector.initialize(CoyoteConnector.java:1032)
at org.apache.catalina.core.StandardService.initialize(StandardService.java:579)
at org.apache.catalina.core.StandardServer.initialize(StandardServer.java:2245)
at org.apache.catalina.startup.CatalinaService.load(CatalinaService.java:236)
at org.apache.catalina.startup.CatalinaService.load(CatalinaService.java:258)
at java.lang.reflect.Method.invoke(Native Method)
at org.apache.catalina.startup.BootstrapService.init(BootstrapService.java:231)
at org.apache.catalina.startup.BootstrapService.main(BootstrapService.java:297)
[ERROR] Http11Protocol - -Error initializing endpoint
java.net.SocketException: Not connected: JVM_Bind
at java.net.PlainSocketImpl.socketBind(Native Method)
at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:405)
at java.net.ServerSocket.(ServerSocket.java:170)
at java.net.ServerSocket.(ServerSocket.java:121)
at org.apache.tomcat.util.net.DefaultServerSocketFactory.createSocket(DefaultServerSocketFactory.java:96)
at org.apache.tomcat.util.net.PoolTcpEndpoint.initEndpoint(PoolTcpEndpoint.java:265)
at org.apache.tomcat.util.net.PoolTcpEndpoint.startEndpoint(PoolTcpEndpoint.java:287)
at org.apache.coyote.http11.Http11Protocol.start(Http11Protocol.java:161)
at org.apache.coyote.tomcat4.CoyoteConnector.start(CoyoteConnector.java:1056)
at org.apache.catalina.core.StandardService.start(StandardService.java:506)
at org.apache.catalina.core.StandardServer.start(StandardServer.java:2189)
at org.apache.catalina.startup.CatalinaService.start(CatalinaService.java:273)
at java.lang.reflect.Method.invoke(Native Method)
at org.apache.catalina.startup.BootstrapService.start(BootstrapService.java:245)
at org.apache.catalina.startup.BootstrapService.main(BootstrapService.java:307)
[ERROR] Http11Protocol - -Error starting endpoint

Re: Tomcat startup failing?

Posted By:   Daniele_Galluccio  
Posted On:   Thursday, May 1, 2003 10:59 AM

did you try to redirect stdout and stderr to a file? (when launching startup I mean)
About | Sitemap | Contact