send image in bytemesage
0 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Ben_Cai
Posted On:   Saturday, April 12, 2003 01:10 AM

i have a jms application to send messages to mq server through a mq client. i tried to send image with bytemessage. i used it for small images (10k, 20k) and it worked fine. however, when i try to send a large image of over 500k, i got error messages: javax.jms.JMSException: MQJMS2007: failed to send message to MQ queue java.lang.Throwable(java.lang.String) java.lang.Exception(java.lang.String) javax.jms.JMSException(java.lang.String, java.lang.String) javax.jms.JMSException com.ibm.mq.jms.services.ConfigEnvironment.newException(java.lang.String) void com.ibm.mq.jms.MQQueueSender.sendInternal(com.ibm.mq.jms.MQQueue, com.ibm.mq.MQQueue, javax.jms.Message, int, int, long) void com.ibm.mq.jms.MQQu   More>>

i have a jms application to send messages to mq server through a mq client. i tried to send image with bytemessage. i used it for small images (10k, 20k) and it worked fine. however, when i try to send a large image of over 500k, i got error messages:


javax.jms.JMSException: MQJMS2007: failed to send message to MQ queue
java.lang.Throwable(java.lang.String)
java.lang.Exception(java.lang.String)
javax.jms.JMSException(java.lang.String, java.lang.String)
javax.jms.JMSException com.ibm.mq.jms.services.ConfigEnvironment.newException(java.lang.String)
void com.ibm.mq.jms.MQQueueSender.sendInternal(com.ibm.mq.jms.MQQueue, com.ibm.mq.MQQueue, javax.jms.Message, int, int, long)
void com.ibm.mq.jms.MQQueueSender.send(javax.jms.Message, int, int, long)
void com.ibm.mq.jms.MQQueueSender.send(javax.jms.Message)
void ca.sears.ecommerce.tools.dataload.util.PointToPointMessenger.sendByteMessage(java.util.Hashtable, java.io.FileInputStream)
void ca.sears.ecommerce.tools.dataload.util.SendMessageTest2.run()


the interesting thing is that it does not fail every time. for half of the time, it will go through. another problem is that when message arrives in the queue, the message size turned to be over 2mb. i tried .jpg .gif .fpx, they are all the same. i am not sure why.


does anyone have same experience and some solution?


thanks!
ben

   <<Less
About | Sitemap | Contact