Simple Servlet connection to Database in JBuilder8 ????
2 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   fresh_guy
Posted On:   Monday, March 24, 2003 12:58 AM

I have installed new version Jbuilder8 under c:JBuilder8. and i had classes12.zip under c:jars. My program is simply a servlet connecting to database(oracle) using thin driver. Is there separate path settings (for JBuilder to identify classes12.zip) for both Compilation and Runing ?? Because at the compilation time(using ProjectProperties) when i add classes12.zip in the RequiredLibraries tag, its not giving compilation error as its giving before. And now when i started running(using Run), its throwing java.lang.NoClassDefFoundError: oracle/jdbc/driver/OracleDriver What   More>>

			




I have installed new version Jbuilder8
under c:JBuilder8. and i had classes12.zip
under c:jars.

My program is simply a servlet
connecting to database(oracle) using thin
driver.

Is there separate path settings
(for JBuilder to identify classes12.zip)
for both Compilation and Runing ??

Because at the compilation time(using ProjectProperties)
when i add classes12.zip in the RequiredLibraries tag,
its not giving compilation error as its giving before.
And now when i started running(using Run), its throwing
java.lang.NoClassDefFoundError: oracle/jdbc/driver/OracleDriver

What should i do now ??
please iam newbie to Jbuilder.
help is appreciated.

thanks



   <<Less

Re: Simple Servlet connection to Database in JBuilder8 ????

Posted By:   fresh_guy  
Posted On:   Tuesday, March 25, 2003 08:01 PM





yes i got now,
thanks for ur responses,
here after i add the classes12.zip under
menu->project->projectProperties->server->checking jsp/servlet->cliking on right button->requiredLibraries->Add->..


i got the servlet displaying the result.

but this is entirely crazy solution i think,
i would like to know the correct documentation
where can i please ???

thanks.
venu.



Re: Simple Servlet connection to Database in JBuilder8 ????

Posted By:   Christopher_Koenigsberg  
Posted On:   Monday, March 24, 2003 09:58 AM

Try renaming 'classes12.zip', to 'classes12.jar'?


Are you using container connection pooling and/or JNDI lookup for the data source, where you need to have one copy global to the whole server runtime environment?



If not (or even try this temporarily for testing to see if it works, helping you narrow down your problem), try putting the classes12 file directly in the web application's WEB-INF/lib directory (in addition to renaming it, from 'classes12.zip' to 'classes12.jar').

About | Sitemap | Contact