Exception during startup processing
0 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Justin_Hannus
Posted On:   Sunday, March 2, 2003 02:01 PM

Please forgive me if this is not the right place for this topic. (running tomcat tomcat-4.1.18/jdk 1.3.1 on MacOSX 10.2.3) I installed tomcat-4.1.18 (the binary dist) last week and it was running properly until I restarted it today. Now when I try to start it it says the usual output: Using CATALINA_BASE: /usr/local/jakarta-tomcat-4.1.18 Using CATALINA_HOME: /usr/local/jakarta-tomcat-4.1.18 Using CATALINA_TMPDIR: /usr/local/jakarta-tomcat-4.1.18/temp Using JAVA_HOME: /System/Library/Frameworks/JavaVM.framework/Versions/1.3.1/Home But it doesn't start. The logs tell me that: Exception during startup processing java.lang.reflect.InvocationTargetException: java.lan   More>>

Please forgive me if this is not the right place for this topic.

(running tomcat tomcat-4.1.18/jdk 1.3.1 on MacOSX 10.2.3)
I installed tomcat-4.1.18 (the binary dist) last week and it was running properly until I restarted it today. Now when I try to start it it says the usual output:


Using CATALINA_BASE: /usr/local/jakarta-tomcat-4.1.18
Using CATALINA_HOME: /usr/local/jakarta-tomcat-4.1.18
Using CATALINA_TMPDIR: /usr/local/jakarta-tomcat-4.1.18/temp
Using JAVA_HOME: /System/Library/Frameworks/JavaVM.framework/Versions/1.3.1/Home


But it doesn't start. The logs tell me that:


Exception during startup processing
java.lang.reflect.InvocationTargetException: java.lang.NoSuchMethodError
at org.apache.commons.digester.Digester.getXMLReader(Digester.java:892)
at org.apache.commons.digester.Digester.parse(Digester.java:1495)
at org.apache.catalina.startup.Catalina.start(Catalina.java:449)
at org.apache.catalina.startup.Catalina.execute(Catalina.java:400)
at org.apache.catalina.startup.Catalina.process(Catalina.java:180)
at java.lang.reflect.Method.invoke(Native Method)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:203)


Thats wired cause the libs its talking about are part of the distrobution. I'm thinking this has something to do with tomcat not being able to find and xml package like xerces or something. I thought this happened after I installed the java xml pack into $JAVA_HOME/lib/ext but I since took it out and the problem persists. I haven't done any configuring to tomcat or installed any classes/web apps that would cause any conflicts either, since I'm still learning tomcat. Does anyone have any ideas on what to do?    <<Less
About | Sitemap | Contact