cannot find class xdoclet.ejb.EjbDocletTask
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   mei_xiao
Posted On:   Thursday, January 30, 2003 04:57 PM

Hi:

I just installed XDoclet-1.2b2, and try some sample codes.

But I always got same error:
taskdef class xdoclet.ejb.EjbDocletTask cannot be found.


I checked xdoclet-1.2b2.jar, xdoclet.ejb.EjbDocletTask is not in there. Can any body tell me which jar file xdoclet.ejb.EjbDocletTask is in?


I tried to copy xdoclet-1.2b2.jar to ant_home/lib. or
set xdoclet-1.2b2.jar in classpath without luck.
What shall I do to setup the environment for XDoclet?

Thank you!

Mei Xiao

Re: cannot find class xdoclet.ejb.EjbDocletTask

Posted By:   Anonymous  
Posted On:   Thursday, January 30, 2003 05:38 PM

xdoclet.ejb.EjbDocletTask is in xdoclet-ejb-module-1.2b2.jar. -And it's deprecated. Use xdoclet.ejb.EjbDocletTask instead.


But that's not the real problem. Run ant with -debug, and you'll see what's really missing. Also make sure you put the javax.ejb.* classes on the classpath.


HTH,

Aslak

About | Sitemap | Contact