TreeParserErrorMessage: Suffixing a root node with '!' is not implemented
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Tobias_Lindig
Posted On:   Thursday, January 30, 2003 03:55 AM


#(FUNCTIONCALL functionIdent:IDENT! (#(arg:ARGUMENTS! eList:exprList!))? cObject:calledObject! )


For rules like this I got a error by the new antlr2.7.2 but the antlr2.7.1 could handle it. Why was it changed? Will it be implemented in the next time or have I to change my grammar?


thanks,

tob

Re: TreeParserErrorMessage: Suffixing a root node with '!' is not implemented

Posted By:   Tobias_Lindig  
Posted On:   Monday, February 3, 2003 03:38 AM

Here I am again.


just I made the workaround and I fixed the compiling problems for compile antlr with visual c++ 6 (thanks to Patrick Scheller for the support). but I can not use antlr yet. I got 240 errors for my project (with antlr2.7.1 it compiles error free, and I use the lexer, parser and treeparser). so i have to resume that antlr2.7.2 is not in a releas-state.


so keep your copys of 2.7.1, because the download for 2.7.1 is replaced by download for 2.7.2, but 2.7.2 is not yet a acceptable replacement.


tob

About | Sitemap | Contact