dcsimg
Session Cookie lost on close for the child window in IE 6.0
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Marina_Rotenberg
Posted On:   Tuesday, December 24, 2002 12:38 PM

We are using Struts, JSP/Servlets for our project. There is also little pop up window that is being used to display calendar. It is called via JavaScrip window.open() Everything worked OK until we upgraded from IE 5.5 to 6.0 In the new version of IE whenever child (calendar) window is closed, the session cookie is lost. I tried changing the STRUTS example to see if I can reproduce it there. I added one simple/empty pop up to open from the login page. Whenever this popup is closed Struts example looses session cookie and user is redirected to the login screen. I know that there is confirmed problem in IE6.0 (see URL below) that seems to fit our issue well. The problem is that this was supposed to be fixed with the se   More>>

We are using Struts, JSP/Servlets for our project. There is also little pop up window that is being used to display calendar. It is called via JavaScrip window.open() Everything worked OK until we upgraded from IE 5.5 to 6.0
In the new version of IE whenever child (calendar) window is closed, the session cookie is lost.


I tried changing the STRUTS example to see if I can reproduce it there. I added one simple/empty pop up to open from the login page. Whenever this popup is closed Struts example looses session cookie and user is redirected to the login screen.


I know that there is confirmed problem in IE6.0 (see URL below) that seems to fit our issue well. The problem is that this was supposed to be fixed with the service pack 1 for IE 6.0. I installed the service pack but that did not help.


http://support.microsoft.com/default.aspx?scid=kb;en-us;315713


IE 6.0 now is part of standard image on our customer PCs. We have to support it. Any help or workaround would be greatly appreciated.

   <<Less

Re: Session Cookie lost on close for the child window in IE 6.0

Posted By:   Trejkaz_Xaoza  
Posted On:   Friday, December 27, 2002 05:43 AM

We had the same problem at work but it was only happening when the user visited a file:// URL at some point before opening the original window. In our case the 'user' (the demo computer) was going to a start page which showed a list of all the demo machines, and this start page was on the demo machine's local disk.



Moved the page to a server on the intranet and it stopped the problem. Hope this helps you too.

About | Sitemap | Contact