dcsimg
Simple Web App NOT Working with JBoss + IDEA
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Hari_Om
Posted On:   Wednesday, December 18, 2002 04:04 PM

Hi Experts: I am using TOMCAT_4.0.3 (bundled with JBOSS_3.0.0) and using IntelliJ-IDEA as my IDE environment. On one of my machine I created a WEB-APP kithany.war. It was working fine on this machine. Later when I copied this kithany.war to other machine and put under server/default/deploy directory and then ran Jboss on which I get following error - wonder why? ------------------------------------------------------ 13:32:34,078 INFO [MainDeployer] Starting deployment of package: file:/C:/jboss-3.0.0_tomcat-4.0.3/server/default/deploy/kithany.war/ 13:32:34,156 INFO [EmbeddedCatalinaServiceSX] deploy, ctxPath=/kithany, warUrl=file:/C:/   More>>

Hi Experts:




I am using TOMCAT_4.0.3 (bundled with JBOSS_3.0.0) and using IntelliJ-IDEA as my IDE environment.



On one of my machine I created a WEB-APP kithany.war. It was working fine on this machine.



Later when I copied this kithany.war to other machine and put under server/default/deploy directory and then ran Jboss on which I get following error - wonder why?



------------------------------------------------------


13:32:34,078 INFO [MainDeployer] Starting deployment of package: file:/C:/jboss-3.0.0_tomcat-4.0.3/server/default/deploy/kithany.war/
13:32:34,156
INFO [EmbeddedCatalinaServiceSX] deploy, ctxPath=/kithany, warUrl=file:/C:/jboss-3.0.0_tomcat-4.0.3/server/default/deploy/kithany.war/

13:32:34,281 ERROR [MainDeployer] could not start deployment: file:/C:/jboss-3.0.0_tomcat-4.0.3/server/default/deploy/kithany.war/

org.jboss.deployment.DeploymentException: Error during deploy; - nested throwable: (java.lang.NullPointerException)

at org.jboss.web.AbstractWebContainer.start(AbstractWebContainer.java:309)
at org.jboss.deployment.MainDeployer.start(MainDeployer.java:678)

at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:513)




java.lang.NullPointerException
at org.jboss.web.catalina.EmbeddedCatalinaServiceSX.createWebContext(EmbeddedCatalinaServiceSX.java:321)

at org.jboss.web.catalina.EmbeddedCatalinaServiceSX.performDeploy(EmbeddedCatalinaServiceSX.java:238)

at org.jboss.web.AbstractWebContainer.start(AbstractWebContainer.java:300)

at org.jboss.deployment.MainDeployer.start(MainDeployer.java:678)

at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:513)




13:32:34,281 ERROR [URLDeploymentScanner] Failed to deploy: org.jboss.deployment.scanner.URLDeploymentScanner$DeployedURL@6417805a{ url=file:/C:/jboss-3.0.0_tomcat-4.0.3/server/default/deploy/kithany.war/, deployedLastModified=0 }

org.jboss.deployment.DeploymentException: Error during deploy; - nested throwable: (java.lang.NullPointerException)

at org.jboss.web.AbstractWebContainer.start(AbstractWebContainer.java:309)

at org.jboss.deployment.MainDeployer.start(MainDeployer.java:678)




------------------------------------------------------


WHat is wrong on this...? Any related information on above is appreciated.


THANKS!

   <<Less

Re: Simple Web App NOT Working with JBoss + IDEA

Posted By:   Serge_Baranov  
Posted On:   Thursday, January 30, 2003 08:06 AM

You can try JBoss integration plug-in for IDEA available from: http://www.intellij.org/twiki/bin/view/Main/JBossIntegration
About | Sitemap | Contact