Ignores the $ character in xdoclet tag (v1.1.2)
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   J_A
Posted On:   Monday, December 2, 2002 09:18 AM


I have extended XmlSubTask to create an xml file from
customised javadoc tags in source code.


This works fine unless there is an $ character within a parameter value, in which case the $ is ignored.


e.g. @custom:a name="xxx$yyy"
gives xxxyyy in the xml.


I am presuming this is some sort of reserved character. Is there any way of telling xdoclets not to strip it out?

Re: Ignores the $ character in xdoclet tag (v1.1.2)

Posted By:   Anonymous  
Posted On:   Monday, December 2, 2002 05:54 PM

XDoclet can do property replacement in code just as in Ant, but in 1.1.2 there are som bugs. If a tag parameter contains a dollar not followed by a left curly brace it will just be stripped off. If you need a dollar, the workaround in 1.1.2 is to define a property in Ant with the desired value:






And refer to that property from your tag:



@custom:a name="${foo}"


I believe this bug has been fixed in 1.2.x, so if you upgrade you can leave your code as is.


HTH,


Aslak

About | Sitemap | Contact