dcsimg
whitespace in path
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Krzysztof_Czysciak
Posted On:   Monday, December 2, 2002 04:26 AM

Hi! I have problems running task from ant 1.5.1 under WinNT4.0. When my build.xml file is stored in directory that contains no whitespaces e.g. "c:software omcat40webappsmyapp" everything works fine, but when I have it under "C:Program FilesApache Tomcat 4.0webappsmyapp" the task fails - displays the following error (using -verbose switch): idl2java: [java] Executing 'C:Softwarej2sdk1.4.1_01jre injava.exe' with arguments: [java] '-classpath' [java] 'C:Program FilesApache Tomcat 4.0...' [java] 'org.openorb.compiler.IdlCompiler' [java] '-silence' [java] '-all' [java] '-d' [java] 'C:Program' [java]    More>>

Hi!



I have problems running task from ant 1.5.1 under WinNT4.0. When my build.xml file is stored in directory that contains no whitespaces e.g. "c:software omcat40webappsmyapp" everything works fine, but when I have it under "C:Program FilesApache Tomcat 4.0webappsmyapp" the task fails - displays the following error (using -verbose switch):





			
idl2java:
[java] Executing 'C:Softwarej2sdk1.4.1_01jre injava.exe' with arguments:
[java] '-classpath'
[java] 'C:Program FilesApache Tomcat 4.0...'
[java] 'org.openorb.compiler.IdlCompiler'
[java] '-silence'
[java] '-all'
[java] '-d'
[java] 'C:Program'
[java] 'FilesApache'
[java] 'Tomcat'
[java] '4.0webappsmyappmyappsrc'
[java] '-I'
[java] 'C:Program'
[java] 'FilesApache'
[java] 'Tomcat'
[java] '4.0webappsmyappidl'
[java] 'C:Program'
[java] 'FilesApache'
[java] 'Tomcat'
[java] '4.0webappsmyappmy.idl'
[java]
[java] The ' characters around the executable and arguments are
[java] not part of the command.
[java] Failed to open idl file: FilesApache.idl





Is there any workaround for this problem? It's not enough to say that I should use "non-whitespace" directory, because this file is also compiled by other developers who usually have whitespaces in these directories.



Thanx,

Kris





My build.xml file contains the following entries:

			













   <<Less

Re: whitespace in path

Posted By:   Erik_Hatcher  
Posted On:   Monday, December 2, 2002 06:27 PM

Rather than use , break it up such that every parameter on the command-line has its own entry. Use for the switches like -I. Use for the values representing files or directories.
About | Sitemap | Contact