dcsimg
[java] java.rmi.ServerException: Missing port information!_NEWLINE_!please help.....
0 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Anonymous
Posted On:   Tuesday, November 12, 2002 06:24 AM

I am having some problems with the Java Web Services. I am following the examples in the Tutorials and am now trying to expand them. I can easily create and deploy a JAXRPC client that calls another class compiled by the apache ant. but when I try to include a new class that uses other jars etc I get the following error..... D:jwsdp-1_0_01docs utorialexamplesjaxrpc est>ant run CLASSPATH Buildfile: build.xml run: [echo] Running the test.TestClient program.... [java] Hello this is a test [java] This came from the test class [java] java.rmi.ServerException: Missing port information [java] at com.sun.xml.rpc.client.StreamingSender._raiseFault(Strea   More>>

I am having some problems with the Java Web Services. I am following the examples in the Tutorials and am now trying to expand them. I can easily create and deploy a JAXRPC client that calls another class compiled by the apache ant. but when I try to include a new class that uses other jars etc I get the following error.....







D:jwsdp-1_0_01docs utorialexamplesjaxrpc est>ant run
CLASSPATH
Buildfile: build.xml

run:
[echo] Running the test.TestClient program....
[java] Hello this is a test
[java] This came from the test class
[java] java.rmi.ServerException: Missing port information
[java] at com.sun.xml.rpc.client.StreamingSender._raiseFault(StreamingS
ender.java:357)
[java] at com.sun.xml.rpc.client.StreamingSender._send(StreamingSender.
java:228)
[java] at test.TestIF_Stub.countryTestName(TestIF_Stub.java:59)
[java] at test.TestClient.main(Unknown Source)
[java] at java.lang.reflect.Method.invoke(Native Method)
[java] at org.apache.tools.ant.taskdefs.ExecuteJava.execute(ExecuteJava
.java:124)
[java] at org.apache.tools.ant.taskdefs.Java.run(Java.java:305)
[java] at org.apache.tools.ant.taskdefs.Java.executeJava(Java.java:127)

[java] at org.apache.tools.ant.taskdefs.Java.execute(Java.java:88)
[java] at org.apache.tools.ant.Task.perform(Task.java:217)
[java] at org.apache.tools.ant.Target.execute(Target.java:184)
[java] at org.apache.tools.ant.Target.performTasks(Target.java:202)
[java] at org.apache.tools.ant.Project.executeTarget(Project.java:601)
[java] at org.apache.tools.ant.Project.executeTargets(Project.java:560)

[java] at org.apache.tools.ant.Main.runBuild(Main.java:454)
[java] at org.apache.tools.ant.Main.start(Main.java:153)
[java] at org.apache.tools.ant.Main.main(Main.java:176)

BUILD SUCCESSFUL

Total time: 30 seconds
[java] at java.lang.reflect.Method.invoke(Native Method)
[java] at com.sun.launcher.Launcher.main(Launcher.java:208)











I know this is not entirely true as the log indicates the class I have asked to be used can not be found. I have added the class to the jwsdp/comon/class and the jars to the lib.


Help.........

thanks,

Paul.

   <<Less
About | Sitemap | Contact