reliability problem
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   tyris_d
Posted On:   Wednesday, October 30, 2002 02:32 AM

hi all, i have been developping webservices since the last past 7 months, so it's not a "how to" problem. I hope that someone could maybe help in finding some clues. Here is my problem: i have made a webservice, with a java client, and a .NET Server. Interop works fine. The server sends back the result, and if the result is an error, it gives the full error message for explanations. This error message is initialized to " " (empty) and can only retrieve a myError.getMessage(). When i call the webservice, it can work for 5,10 or 20 times, but suddenlty i will get a message "Exception". I mean, not the full message, just a string "Exception". If i call back the webservice with the same dat   More>>

hi all,
i have been developping webservices since the last past 7 months, so it's not a "how to" problem.
I hope that someone could maybe help in finding some clues.
Here is my problem:
i have made a webservice, with a java client, and a .NET Server. Interop works fine. The server sends back the result, and if the result is an error, it gives the full error message for explanations. This error message is initialized to " " (empty) and can only retrieve a myError.getMessage().
When i call the webservice, it can work for 5,10 or 20 times, but suddenlty i will get a message "Exception". I mean, not the full message, just a string "Exception". If i call back the webservice with the same data, i could get again an "Exception" or it could work again for 10 times.
So as you can see, it's not easy to reproduce the bug in order to debug it.
I mean usualy, when it really bugs (like an insert problem in a database etc...), i get a full message like "Unexpected end of file from server" or "Must declare the variable '@EMP_ContactId'". My try/catch deals with this..

So i have no idea for the reason of this "Exception" message. No more details, it can bug or work in a random way... It's not a timeout problem as the server answers, but it answers "Exception"... I have never seen this before. A network problem ? a DB problem ? a SOAP problem (when it's a SOAP problem i usualy get an "I/O Exception so i don't thinks it's the case here)?

really weird.
Any help to find a solution would be appreciated.
Regards

Elise
ps: sorry for ùy coarse english.

   <<Less

Re: reliability problem - additionnal info

Posted By:   tyris_d  
Posted On:   Wednesday, October 30, 2002 06:40 AM

by the way, i have the feeling that this "exception" has more chances to appear when the webservice has not been called since a few minutes.

If i make 40 calls sequencialy, i have no "exception", but if i wait 15 min for exampel for the next call, it will give an "exception". and the next call will be fine.


maybe this could help you to help me ;-)
About | Sitemap | Contact