dcsimg
Problem with using java beans in tomcat 4.0
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Jay_K
Posted On:   Tuesday, October 22, 2002 06:09 AM

I have got a JSP file under /webapps/app1/jsp/pages/test.jsp, which calls a bean inside it as follows I have placed Details.class under WEB-INF/lib folder in a jar file called test.jar. when i run the jsp page, it comes up with an error saying Class org.apache.jsp.Details not found. Details regBean = null; what do i have to do to register the bean Details in Tomcat 4.0? What am i doing wrong? Thank you    More>>

I have got a JSP file under /webapps/app1/jsp/pages/test.jsp, which calls a bean inside it as follows











I have placed Details.class under WEB-INF/lib folder in a jar file called test.jar.




when i run the jsp page, it comes up with an error saying



Class org.apache.jsp.Details not found.

Details regBean = null;




what do i have to do to register the bean Details in Tomcat 4.0? What am i doing wrong?




Thank you

   <<Less

Re: Problem with using java beans in tomcat 4.0

Posted By:   Sean_Ruff  
Posted On:   Tuesday, October 22, 2002 07:04 AM

what is the path of the file (Details.class) inside the jar file (if any)? If there is no path as there should not be according to the code listed, then try changing Details.class to add a package statement, repackage the jar file and change your useBean tag accordingly, and give that a try?


My reason for suggesting that is I remember (I think) getting your same results and by adding the class to a package it was corrected.

About | Sitemap | Contact