character Encoding
4 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   philip_johnson
Posted On:   Tuesday, October 1, 2002 05:22 PM

Hi All,
I am getting an exception like this when I get special character from database to XSLT renderer.
"An invalid XML character (Unicode: 0xb3) was found in the element content of the document.".
could u help me to fix this problem

Re: character Encoding

Posted By:   Roseanne_Zhang  
Posted On:   Thursday, October 3, 2002 05:50 PM

Thanks for the other post about Cp1252, your problem can be solved by setting he encoding to "Cp1252"


See here Microsoft Windows Codepage 1252 (ANSI) My confusion of ³ is also solved.

Re: character Encoding

Posted By:   Roseanne_Zhang  
Posted On:   Wednesday, October 2, 2002 07:06 AM

哈哈! Haha! in Chinese as unicode & # 21704 ;


A byproduct learned by researching your question, not bad! Thank you!

Re: character Encoding

Posted By:   Roseanne_Zhang  
Posted On:   Wednesday, October 2, 2002 06:48 AM

Oh, my God!
& # 179 ; (take out the spaces) became ³ . Interesting! It is not the same as in the table. However, now I'm sure, the escape strategy will work. Haha!

Re: character Encoding

Posted By:   Roseanne_Zhang  
Posted On:   Wednesday, October 2, 2002 06:41 AM

Look at here:
Extended ASCII Codes



0xb3 is 179. You might preprocess your data, to escape the character. Try change it to ³ to see if it works. If it does not, then you might need to define it in your DTD. My guess is it might work, but I'm not sure until you try.

About | Sitemap | Contact