Should I ever use the Java 1.0 event handling mechanisms?

John Zukowski

In most cases, the answer is no. Around 90% of the browsers people use support the Java 1.1 AWT capabilities. However, if you really want to hit 100% and not lock out some users, than you are stuck with the 1.0 world. Of course, this also means that the users are at a security risk, as there have been many security fixes since the older browser releases, for both Java and JavaScript.

[FAQ Manager note] You can also put a note on your web page stating "You need Java 1.1 support to view this applet". The 1.1 browsers have been available for long enough that it's really fair to expect your users to upgrade.

Comment and Contribute






(Maximum characters: 1200). You have 1200 characters left.



About | Sitemap | Contact